package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^value:\s?([^-\n]+)(?:\s-.*?-\s)?([^-\n]*)(?:\s|$)`)
var str = `value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE...
value: 75 MG - OM - PO/TUBE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}