using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^value:\s?([^-\n]+)(?:\s-.*?-\s)?([^-\n]*)(?:\s|$)";
string input = @"value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE...
value: 75 MG - OM - PO/TUBE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}