#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/([^\s]+)"
Local $sString = "https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст" & @CRLF & _
"" & @CRLF & _
"https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст" & @CRLF & _
"" & @CRLF & _
"https://diso.ru/{%iftype=='webinar'%}webinar{#comment#}{%else%}profile{{type}}{%endif%}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")