import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/([^\\s]+)";
final String string = "https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст\n\n"
+ "https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст\n\n"
+ "https://diso.ru/{%iftype=='webinar'%}webinar{#comment#}{%else%}profile{{type}}{%endif%}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}