using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/([^\s]+)";
string input = @"https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст
https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст
https://diso.ru/{%iftype=='webinar'%}webinar{#comment#}{%else%}profile{{type}}{%endif%}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}