using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"posta2010@(.*)";
string input = @"posta2010@apple.com
ddd@apple.csom
posta2010@dddd
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}