re = /posta2010@(.*)/i
str = 'posta2010@apple.com
ddd@apple.csom
posta2010@dddd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end