$re = '/posta2010@(.*)/i';
$str = 'posta2010@apple.com
ddd@apple.csom
posta2010@dddd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);