using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1[01]*(?:\.[01]{0,31}1)?$";
string input = @"1.001100101
1.0000000000000010
1
0
0.1
1..1
1.1
1.000000000000001
1.01010101010101010101010101010101
1.010101010101010101010101010101011
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}