import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1[01]*(?:\\.[01]{0,31}1)?$";
final String string = "1.001100101\n"
+ "1.0000000000000010\n"
+ "1\n"
+ "0\n"
+ "0.1\n"
+ "1..1\n"
+ "1.1\n"
+ "1.000000000000001\n"
+ "1.01010101010101010101010101010101\n"
+ "1.010101010101010101010101010101011\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}