const regex = /^1[01]*(?:\.[01]{0,31}1)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1[01]*(?:\\.[01]{0,31}1)?$', 'gm')
const str = `1.001100101
1.0000000000000010
1
0
0.1
1..1
1.1
1.000000000000001
1.01010101010101010101010101010101
1.010101010101010101010101010101011
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}