#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "COALESCE\((.*?)\)"
Local $sString = "select DISTINCT SUM(case when t0_0.pp is not null then COALESCE(t0_0.pp,0)" & @CRLF & _
"else 0 end) from inventory_coverage_view t0_0 where LOWER(t0_0.h) ='vg' AND t0_0.id = '9'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")