const regex = new RegExp('COALESCE\\((.*?)\\)', 'g')
const str = `select DISTINCT SUM(case when t0_0.pp is not null then COALESCE(t0_0.pp,0)
else 0 end) from inventory_coverage_view t0_0 where LOWER(t0_0.h) ='vg' AND t0_0.id = '9'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}