$re = '/COALESCE\((.*?)\)/';
$str = 'select DISTINCT SUM(case when t0_0.pp is not null then COALESCE(t0_0.pp,0)
else 0 end) from inventory_coverage_view t0_0 where LOWER(t0_0.h) =\'vg\' AND t0_0.id = \'9\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);