using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"COALESCE\((.*?)\)";
string input = @"select DISTINCT SUM(case when t0_0.pp is not null then COALESCE(t0_0.pp,0)
else 0 end) from inventory_coverage_view t0_0 where LOWER(t0_0.h) ='vg' AND t0_0.id = '9'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}