#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\W_][\w\-\.]*[^\W_])(@[^\W_][a-zA-Z0-9\-]+[^\W_])(\.[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)?[^\W_])$"
Local $sString = "// User tests" & @CRLF & _
"abc@test.test" & @CRLF & _
"123@test.test" & @CRLF & _
"abc123@test.test" & @CRLF & _
"abc.123@test.test" & @CRLF & _
"abc-123@test.test" & @CRLF & _
"abc_123@test.test" & @CRLF & _
"abc.123-def@test.test" & @CRLF & _
"abc.123_def@test.test" & @CRLF & _
"abc-123_def@test.test" & @CRLF & _
"" & @CRLF & _
"// Domain tests" & @CRLF & _
"test@abc.test" & @CRLF & _
"test@123.test" & @CRLF & _
"test@abc-123.test" & @CRLF & _
"" & @CRLF & _
"// TLD tests" & @CRLF & _
"test@test.com" & @CRLF & _
"test@test.com.br" & @CRLF & _
"" & @CRLF & _
"//Invalid space tests" & @CRLF & _
" test@test.test" & @CRLF & _
"te st@test.test" & @CRLF & _
"test @test.test" & @CRLF & _
"test@ test.test" & @CRLF & _
"test@te st.test" & @CRLF & _
"test@test .test" & @CRLF & _
"test@test. test" & @CRLF & _
"test@test.te st" & @CRLF & _
"test@test.test " & @CRLF & _
"" & @CRLF & _
"//Invalid user tests" & @CRLF & _
".abc123@test.test" & @CRLF & _
"abc123.@test.test" & @CRLF & _
"-abc123@test.test" & @CRLF & _
"abc123-@test.test" & @CRLF & _
"_abc123@test.test" & @CRLF & _
"abc123_@test.test" & @CRLF & _
"" & @CRLF & _
"//Invalid domain tests" & @CRLF & _
"test@.abc123.test" & @CRLF & _
"test@abc123..test" & @CRLF & _
"test@-abc123.test" & @CRLF & _
"test@abc123-.test" & @CRLF & _
"test@_abc123.test" & @CRLF & _
"test@abc_123.test" & @CRLF & _
"test@abc123_.test" & @CRLF & _
"" & @CRLF & _
"//Invalid TLD tests" & @CRLF & _
"test@test.abc." & @CRLF & _
"test@test.-abc" & @CRLF & _
"test@test.ab-c" & @CRLF & _
"test@test.abc-" & @CRLF & _
"test@test._abc" & @CRLF & _
"test@test.ab_c" & @CRLF & _
"test@test.abc_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")