use strict;
my $str = '// User tests
abc@test.test
123@test.test
abc123@test.test
abc.123@test.test
abc-123@test.test
abc_123@test.test
abc.123-def@test.test
abc.123_def@test.test
abc-123_def@test.test
// Domain tests
test@abc.test
test@123.test
test@abc-123.test
// TLD tests
test@test.com
test@test.com.br
//Invalid space tests
test@test.test
te st@test.test
test @test.test
test@ test.test
test@te st.test
test@test .test
test@test. test
test@test.te st
test@test.test
//Invalid user tests
.abc123@test.test
abc123.@test.test
-abc123@test.test
abc123-@test.test
_abc123@test.test
abc123_@test.test
//Invalid domain tests
test@.abc123.test
test@abc123..test
test@-abc123.test
test@abc123-.test
test@_abc123.test
test@abc_123.test
test@abc123_.test
//Invalid TLD tests
test@test.abc.
test@test.-abc
test@test.ab-c
test@test.abc-
test@test._abc
test@test.ab_c
test@test.abc_';
my $regex = qr/^([^\W_][\w\-\.]*[^\W_])(@[^\W_][a-zA-Z0-9\-]+[^\W_])(\.[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)?[^\W_])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}