package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\W_][\w\-\.]*[^\W_])(@[^\W_][a-zA-Z0-9\-]+[^\W_])(\.[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)?[^\W_])$`)
var str = `// User tests
abc@test.test
123@test.test
abc123@test.test
abc.123@test.test
abc-123@test.test
abc_123@test.test
abc.123-def@test.test
abc.123_def@test.test
abc-123_def@test.test
// Domain tests
test@abc.test
test@123.test
test@abc-123.test
// TLD tests
test@test.com
test@test.com.br
//Invalid space tests
test@test.test
te st@test.test
test @test.test
test@ test.test
test@te st.test
test@test .test
test@test. test
test@test.te st
test@test.test
//Invalid user tests
.abc123@test.test
abc123.@test.test
-abc123@test.test
abc123-@test.test
_abc123@test.test
abc123_@test.test
//Invalid domain tests
test@.abc123.test
test@abc123..test
test@-abc123.test
test@abc123-.test
test@_abc123.test
test@abc_123.test
test@abc123_.test
//Invalid TLD tests
test@test.abc.
test@test.-abc
test@test.ab-c
test@test.abc-
test@test._abc
test@test.ab_c
test@test.abc_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}