import Foundation
let pattern = #"^([^\W_][\w\-\.]*[^\W_])(@[^\W_][a-zA-Z0-9\-]+[^\W_])(\.[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)?[^\W_])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// User tests
abc@test.test
123@test.test
abc123@test.test
abc.123@test.test
abc-123@test.test
abc_123@test.test
abc.123-def@test.test
abc.123_def@test.test
abc-123_def@test.test
// Domain tests
test@abc.test
test@123.test
test@abc-123.test
// TLD tests
test@test.com
test@test.com.br
//Invalid space tests
test@test.test
te st@test.test
test @test.test
test@ test.test
test@te st.test
test@test .test
test@test. test
test@test.te st
test@test.test
//Invalid user tests
.abc123@test.test
abc123.@test.test
-abc123@test.test
abc123-@test.test
_abc123@test.test
abc123_@test.test
//Invalid domain tests
test@.abc123.test
test@abc123..test
test@-abc123.test
test@abc123-.test
test@_abc123.test
test@abc_123.test
test@abc123_.test
//Invalid TLD tests
test@test.abc.
test@test.-abc
test@test.ab-c
test@test.abc-
test@test._abc
test@test.ab_c
test@test.abc_
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)