#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bi\K(?:pad|phone)\b|[a-z]+"
Local $sString = "the ipad has gone out of stock" & @CRLF & _
"power up your iphone" & @CRLF & _
"what model is your apple iphone" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"strings with monkeywrenching words..." & @CRLF & _
"" & @CRLF & _
"fly the chopper to the helipad" & @CRLF & _
"an audiphone is a type of hearing aid" & @CRLF & _
"consisting of a diaphragm that, when" & @CRLF & _
"placed against the upper teeth, conveys" & @CRLF & _
"sound vibrations to the inner ear"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")