import Foundation
let pattern = #"\bi\K(?:pad|phone)\b|[a-z]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
the ipad has gone out of stock
power up your iphone
what model is your apple iphone
---
strings with monkeywrenching words...
fly the chopper to the helipad
an audiphone is a type of hearing aid
consisting of a diaphragm that, when
placed against the upper teeth, conveys
sound vibrations to the inner ear
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)