$re = '/\bi\K(?:pad|phone)\b|[a-z]+/';
$str = 'the ipad has gone out of stock
power up your iphone
what model is your apple iphone
---
strings with monkeywrenching words...
fly the chopper to the helipad
an audiphone is a type of hearing aid
consisting of a diaphragm that, when
placed against the upper teeth, conveys
sound vibrations to the inner ear';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);