const regex = /\bi\K(?:pad|phone)\b|[a-z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bi\\K(?:pad|phone)\\b|[a-z]+', 'g')
const str = `the ipad has gone out of stock
power up your iphone
what model is your apple iphone
---
strings with monkeywrenching words...
fly the chopper to the helipad
an audiphone is a type of hearing aid
consisting of a diaphragm that, when
placed against the upper teeth, conveys
sound vibrations to the inner ear`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}