# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\K\R(.)/$1/gm;t' <<< "la la la
da da da
la la la
da da da "