use strict;
my $str = 'la la la
da da da
la la la
da da da ';
my $regex = qr/^.*\K\R(.)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";