const regex = new RegExp('^[a-zA-Z ]+$', 'gm')
const str = `Bruce Schneier
Schneier, Bruce
Schneier, Bruce Wayne
O'Malley, John F.
John O'Malley-Smith
Cher`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}