re = /^[a-zA-Z ]+$/m
str = 'Bruce Schneier
Schneier, Bruce
Schneier, Bruce Wayne
O\'Malley, John F.
John O\'Malley-Smith
Cher'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end