$re = '/^[a-zA-Z ]+$/m';
$str = 'Bruce Schneier
Schneier, Bruce
Schneier, Bruce Wayne
O\'Malley, John F.
John O\'Malley-Smith
Cher';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);