#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+"
Local $sString = "HCl + Na -> NaCl + H2" & @CRLF & _
"" & @CRLF & _
"2 HCl + 2 Na -> 2 NaCl + H2" & @CRLF & _
"" & @CRLF & _
"12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")