package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+`)
var str = `HCl + Na -> NaCl + H2
2 HCl + 2 Na -> 2 NaCl + H2
12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}