import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+";
final String string = "HCl + Na -> NaCl + H2\n\n"
+ "2 HCl + 2 Na -> 2 NaCl + H2\n\n"
+ "12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}