re = /\w+/
str = 'HCl + Na -> NaCl + H2
2 HCl + 2 Na -> 2 NaCl + H2
12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end