package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[<a\s]?(([^\s=]+)="([^"]+)")+>?`)
var str = `<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com" target="_blank" data-id="f">Link text</a>
<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com">Link text</a>
<a>Link text</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}