import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[<a\\s]?(([^\\s=]+)=\"([^\"]+)\")+>?";
final String string = "<a href=\"https://google.com\" target=\"_blank\" title=\"myTitle\">Link text</a>\n"
+ "<a href=\"https://google.com\" target=\"_blank\" data-id=\"f\">Link text</a>\n"
+ "<a href=\"https://google.com\" target=\"_blank\" title=\"myTitle\">Link text</a>\n"
+ "<a href=\"https://google.com\">Link text</a>\n"
+ "<a>Link text</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}