const regex = /[<a\s]?(([^\s=]+)="([^"]+)")+>?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[<a\\s]?(([^\\s=]+)="([^"]+)")+>?', 'gm')
const str = `<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com" target="_blank" data-id="f">Link text</a>
<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com">Link text</a>
<a>Link text</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}