$re = '/[<a\s]?(([^\s=]+)="([^"]+)")+>?/m';
$str = '<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com" target="_blank" data-id="f">Link text</a>
<a href="https://google.com" target="_blank" title="myTitle">Link text</a>
<a href="https://google.com">Link text</a>
<a>Link text</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);