package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?\n?.*?\.)(?:.*\(Reminder (\d*)\))?`)
var str = `L-I-F-123Dolor sit amet. (Reminder 3)
L-I-F-123 Dolor sit amet.
L-I-F-123 Dolor sit amet. Lorem Ipsum.
But these break :
L-I-F-123 Dolor sit amet
L-I-F-123 Dolor sit amet. Lorem Ipsum
L-I-F-123 Dolor sit amet.(Lorem Ipsum)
L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}