re = /^(.*?\n?.*?\.)(?:.*\(Reminder (\d*)\))?/m
str = 'L-I-F-123Dolor sit amet. (Reminder 3)
L-I-F-123 Dolor sit amet.
L-I-F-123 Dolor sit amet. Lorem Ipsum.
But these break :
L-I-F-123 Dolor sit amet
L-I-F-123 Dolor sit amet. Lorem Ipsum
L-I-F-123 Dolor sit amet.(Lorem Ipsum)
L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end