import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?\\n?.*?\\.)(?:.*\\(Reminder (\\d*)\\))?";
final String string = "L-I-F-123Dolor sit amet. (Reminder 3)\n"
+ "L-I-F-123 Dolor sit amet.\n"
+ "L-I-F-123 Dolor sit amet. Lorem Ipsum.\n"
+ "But these break :\n\n"
+ "L-I-F-123 Dolor sit amet\n"
+ "L-I-F-123 Dolor sit amet. Lorem Ipsum\n"
+ "L-I-F-123 Dolor sit amet.(Lorem Ipsum)\n"
+ "L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}