import re
regex = re.compile(r"^(.*?\n?.*?\.)(?:.*\(Reminder (\d*)\))?", flags=re.MULTILINE)
test_str = ("L-I-F-123Dolor sit amet. (Reminder 3)\n"
"L-I-F-123 Dolor sit amet.\n"
"L-I-F-123 Dolor sit amet. Lorem Ipsum.\n"
"But these break :\n\n"
"L-I-F-123 Dolor sit amet\n"
"L-I-F-123 Dolor sit amet. Lorem Ipsum\n"
"L-I-F-123 Dolor sit amet.(Lorem Ipsum)\n"
"L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")