using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhas\s(?:(?!\bhas\b)[^,.""]){0,50}?\bdone\b";
string input = @"The Batman has never shown his true identity but has done so much good for Gotham City";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}