const regex = new RegExp('\\bhas\\s(?:(?!\\bhas\\b)[^,."]){0,50}?\\bdone\\b', 'gm')
const str = `The Batman has never shown his true identity but has done so much good for Gotham City`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}