re = /\bhas\s(?:(?!\bhas\b)[^,."]){0,50}?\bdone\b/m
str = 'The Batman has never shown his true identity but has done so much good for Gotham City'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end