$re = '/\bhas\s(?:(?!\bhas\b)[^,."]){0,50}?\bdone\b/m';
$str = 'The Batman has never shown his true identity but has done so much good for Gotham City';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);