$re = '/^([^.]*).*/m';
$str = 'test_2.3005.i-rewq873.example.local';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;