re = /^([^.]*).*/m
str = 'test_2.3005.i-rewq873.example.local'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result