using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+@gmail\.com$";
string input = @"[no word]@gmail.com
[space]@gmail.com
xxx@gmail.com[any word]
xxx@gmail..com
xxx@gmail/.com
xxx@gmail/com
abc@gmail.com
abc1234@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}