const regex = /^\w+@gmail\.com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+@gmail\\.com$', 'gm')
const str = `[no word]@gmail.com
[space]@gmail.com
xxx@gmail.com[any word]
xxx@gmail..com
xxx@gmail/.com
xxx@gmail/com
abc@gmail.com
abc1234@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}