re = /^\w+@gmail\.com$/m
str = '[no word]@gmail.com
[space]@gmail.com
xxx@gmail.com[any word]
xxx@gmail..com
xxx@gmail/.com
xxx@gmail/com
abc@gmail.com
abc1234@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end