$re = '/^\w+@gmail\.com$/m';
$str = '[no word]@gmail.com
[space]@gmail.com
xxx@gmail.com[any word]
xxx@gmail..com
xxx@gmail/.com
xxx@gmail/com
abc@gmail.com
abc1234@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);